The Game Hangs All The Time!

  • A DNS flush might do the trick. Or setting a neutral DNS like the one from google. If you don't know how to do them, tell me your operating system and I am happy to find out for you

    I'd appreciate that. It's macOS Catalina v.10.15.4. The browser is Safari 13.1

  • Saphirus

    When I have a problem it is on all browsers (Chrome, Firefox, Edge). WIn 10 64

    I have a problem with both HTML 5 and Flash Servers!

    Clearing browser's cache and flash cache doesn't help.

    Sometimes using a VPN server helps.

    Very often I have to press F5 (reload) to fully load the game.

    If I don't press reload, it will never* open (I've tried many times/*In very rare cases, waiting helps).

    Often, with the help of reload, it becomes relatively fast. (fast - I have to reload it 1-5 times to open the server)

    It seems as if the load is hanging it doesn't try again!!!


    And the problem does not always occur.

    Sometimes for a long time there is no problem. But when it is, it's horror!

    And sometimes there is a problem for a very long time


    Mostly there are problems in the evening. When Internet traffic is the busiest.

    But I have no problem opening other sites.


    The most common (but not only) problem occurs in the following 3 cases:

    1. When opening the lobby. Freezes at 50% - during some validation (like The Game Hangs All The Time!)

    https://mellon-rn.traviangames.com/ajax/session-validate/accountid/....

    2.When loading a game - right from the start - I don't know what it loads

    3.When loading a game - after the middle...

    ??????.dat - very big ".dat" file with some game data

  • I'd appreciate that. It's macOS Catalina v.10.15.4. The browser is Safari 13.1

    Ok, here is how DNS flush should work on your operating system:


    1. Launch Terminal, and type below command first.

    2. Type the following and press Enter:

    sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder

    3. Then it will ask to enter a password. Enter your Mac login password and hit Enter.


    And this should be the procedure to delete single cookies from Safari:

    1. Select the gear icon to open Safari's menu and select Preferences.

    2. Select the Privacy tab, then select Details.

    3. Search for railnation and rail-nation and remove the cookies.

  • Hm, but for you the problem is not permanent?
    The "lobby loads only 50%" bug happens for me too from time to time. Reload normally fixes it.

    The game not loading could be a routing problem or some problem between your PC and our server. Especially when using a VPN fixes it.

    Could you please visit our looking glass page:
    Travian Games GmbH - Looking Glass - Looking Glass

    1. click on your displayed IP address. It will be pasted into the text box.

    2. chose mtr from the dropdown

    3. press the "run test" button
    And then post the result here.
    The mtr check will run traceroute from our server to your IP. It's bascially a reverse route to see if anything is wrong with the routing.
    Unfortunately there is no way to do the MTR the other way around (from you to us) without installing a special program in Windows.
    But you could do a normal traceroute.


    1. press windows key

    2. type cmd

    3. in the console type:
    tracert -h 50 s7.railnation.de


    And then post the result here.
    You can chose any other server as well. Whatever you have problems with.

  • Hi,

  • Hey Joe, do you have the same issue as the other players here?
    You got a packet loss on hop 11 and 12, which is not good if those are continuing from hop to hop. On the other hand the final hop has none.
    Might be helpful to hear what kind of issue you have.

  • Saphirus

    1) When there is NO problem


    2) When there IS a little problem (little = 1 game loading refresh)

  • Hey, deleting cookies did not help.

    I couldn't flush the DNS because, for some strange reason, the computer did not accept my password - the password I use all the time :-(

  • Hm, but for you the problem is not permanent?

    Yes, the problem is not permanent for me.

    For me, the problem is mostly in the evening (when the Internet is the busiest).

    Today I had only a few incidents :)

    In fact, in recent days I have had less problems.

    But others are out of luck. They have a constant problem.

    I will give further MTR information when I have bigger problems, if necessary.


    The "lobby loads only 50%" bug happens for me too from time to time. Reload normally fixes it.

    The game not loading could be a routing problem or some problem between your PC and our server. Especially when using a VPN fixes it.

    This freezing occurs up to 10-20 times a day. (I often get in the game)(Problem occurs to me without VPN)

    Yes, reloading helps. But it's annoying.

    In addition, for the consumer, this indicates a low quality of the game. When you have a similar problem before you start loading a game!

    In my opinion, such an amazing game should not have such a spot.

  • As far as I'm concerned, I haven't been able to download for the last 2 days even once, so for me the problem is permanent. Without being able to download, continuing in the game seems pointless. If a number of people have this problem, is anything being done to have it solved at the source?

  • Hey, deleting cookies did not help.

    I couldn't flush the DNS because, for some strange reason, the computer did not accept my password - the password I use all the time :-(

    Hm, do you maybe have an admin password set that you can use instead of your regular password?

  • As far as I'm concerned, I haven't been able to download for the last 2 days even once, so for me the problem is permanent. Without being able to download, continuing in the game seems pointless. If a number of people have this problem, is anything being done to have it solved at the source?

    Well, I am talking to you guys to find the source of the problem. If you known the source, feel free to tell me, it would speed things up considerably. ^ ^ :)

  • Saphirus

    1) When there is NO problem


    2) When there IS a little problem (little = 1 game loading refresh)

    Well to be honest, all the logs look good. There is no significant packet loss, latency is fine. Whatever issues you had yesterday seems were not caused by any routing issue. I will check with our sys admisn and look at the server logs if I see anything that would impact performance more than usual.

    When did this all start for you to get bad? Was it a specific time recently or is it something that you have for a long time? Also, is it just that one server you have the issues with or is it all your servers?

  • Well to be honest, all the logs look good. There is no significant packet loss, latency is fine. Whatever issues you had yesterday seems were not caused by any routing issue. I will check with our sys admisn and look at the server logs if I see anything that would impact performance more than usual.

    When did this all start for you to get bad? Was it a specific time recently or is it something that you have for a long time? Also, is it just that one server you have the issues with or is it all your servers?

    When I have a problem - there is a problem with all the servers. And all browsers.

    Furthermore, there is no difference between flash and HTML 5. I have the same problems with both (I play on many servers).


    My case is complicated if we talk for a long time.

    I have had a similar problem with the game for over a year.

    And as time went on, the problem got bigger.

    At the beginning of the year, I started having too many problems.

    But not just with the game. Many web pages were slow to open.

    I noticed that my internet connection was very slow.

    Then I contacted my ISP.

    And they started analyzing the network and the problem.

    They found that they had a problem with some devices.

    As a result, my internet connection became slow and I had big packet losses - up to 30% to my gateway.

    They replaced the problematic devices. For more than a month, there are no packet losses.

    And internet speed is now normal (high).


    In this moment.

    I thought I would no longer have problems with the game.

    But unfortunately it is not.

    The game problems for me are much less. But they continue.


    What I can see as a problem of the game.

    Is that it is very sensitive to packet loss.

    Even with very high package losses - other sites are opening. Slowly! Slowly but they open.

    But the game has big problems, even with very small packet losses.


    This can be seen with my problem yesterday.

    When there is a 5% packet loss somewhere along the route.

    The game starts freezing. (This is also the case with Joe Blackwater - The Game Hangs All The Time! )


    The game seems to work seamlessly - only when there are no packet losses across the route. When everything is 100% OK.

    Unfortunately, this cannot be expected for an internet connection at such distances.

    The game is played around the world from different devices and different ISPs.


    And it is surprising to me that this problems will not be reflected / noticed anywhere else.

    Everything else works 100% for me.

    Only the Rail Nation has problems.

  • jpxt   Dutcher

    Please test your internet connection with

    Could you please visit our looking glass page:

    Travian Games GmbH - Looking Glass - Looking Glass

    1. click on your displayed IP address. It will be pasted into the text box.

    2. chose mtr from the dropdown

    3. press the "run test" button
    And then post the result here.
    The mtr check will run traceroute from our server to your IP. It's bascially a reverse route to see if anything is wrong with the routing.

  • I'm telling you, It's Telia. RN needs to sort it out with them, it's their own backbone provider who ensures RN/Travian customers get routed correctly and can connect to Travian servers. I have had this issue with all Travian games for the last 10 years. A Telia server or re-router goes haywire and boom, packet loss and loading bars all hang. Once Travian admits to this and calls Telia, it can be sorted out (temporarily, until Telia screws up again).


    But the ignoring of the problem, and finger pointing to players or the "everything is working fine in Germany so the problem has to be with the players' connection or browser" nonsense has to stop.


    PS Travian has contracts with Telia, not the player!

    If it ain't Dutch, it ain't much!

  • Hey, just a quick reply from me right now - I haven't forgotten about this. Thanks for all the additional MTRs, this is really helping us in getting a picture about your situation.
    I will try to give you a detailed answer sometime this weekend. So you have something to look forward to.