RN2018-8123 - HTML5 - Ladebalken bleibt stehen, wenn Tab sich nicht im Vordergrund befindet

  • DerTitel sagts schon. Brandenburger Tor im Hintergrundtab laden lassen während ich im Vordergrundtab das Forum lese funktioniert nicht und der Ladebalken bleibt stehen. Wenn ichs wieder in den Vordergrund bringe lädts normal weiter


    Browser. Vivaldi 2.7.1628.30

  • Kenn ich, gilt für fast alle Spielwelten, ist aber auch schon Ewigkeiten (bei mir) so. Vor einigen Wochen wars noch so, dass wenn man den Tab in den Vordergrund brachte, der Ladebalken wieder bei null anfing.

    Mein PC: Win10 Pro 64bit, spiele mit Edge/v44, 16 GB RAM, i7-6400K-Prozessor, Nvidia GTX 970 mit 4 GB RAM

    Und nein, ich installiere mir keinen anderen Browser. Ich ruf ja auch nicht bei der Stadt an und sage "da ist ein Schlagloch, was repariert werden muss" und bekomm zur Antwort "Kaufen sie sich doch ein anderes Auto".

  • Hallo hilti2, Hallo Quedel,


    für eine präzisere Lösungsfindung des Problems möchte ich euch bitten mir noch diese Dinge mitzuteilen:


    - Internetgeschwindigkeit

    - Firewall

    - Antivirensoftware

    - Browser (gilt speziell für Quedel, da hilti2 es ja schon geschrieben hat)

    Diese Informationen würden uns sehr weiterhelfen. Vielen Dank!


    Liebe Grüße

  • das ist also bei mir auch so. unterschiedliche Computer, unterschiedliche FW (ZyXEL, Sophos), unterschiedliche Internetleitungen (über 100Mbit/s und auch 4G), Unterschiedliche Provider. Browser FF68.0.2 und FF69, Avira

  • DerTitel sagts schon. Brandenburger Tor im Hintergrundtab laden lassen während ich im Vordergrundtab das Forum lese funktioniert nicht und der Ladebalken bleibt stehen. Wenn ichs wieder in den Vordergrund bringe lädts normal weiter


    wenn ich`s mal so sagen darf ....

    das ist doch kein neues spezifisches HTML Problem ?(


    Das grade das Einloggen in einzelne Spielwelten pausiert und dazugehörige Ladebalken stehen bleiben, wenn ich den Tab wechsel und somit die RN Welt in den Hintergrund schiebe und einen anderen Tab aktiv habe.

    das kenne ich schon seit Jahren so und war somit unter Flash schon genauso.

    Das ist leider Spielalltag seit langer Zeit.


    Mir geht es auch oft so, das ich mich in einem Tab in eine RN Welt einloggen will und dabei parallel noch auf Twitter bin oder ne Zeitung lese oder auch einen anderen zweiten RN Tab offen habe .. ganz egal was ... in den allermeisten Fällen bleibt der Ladevorgang der anderen einzuwählenden RN Welt im Hintergrund dabei stehen und geht dann weiter, wen ich diesen Tab wieder aktiv hervorhole.


    Wäre ja wirklich schön, wenn man das mal fixt .. ist aber wie gesagt eigentlich schon ein sehr altes Problem und hat sicher keinen Zusammenhang mit der aktuellen HTML5 Umstellung.

  • neuestes Update schon installiert auf Euerem Browser??

    Das geschilderte Problem gibt es schon sooo lange, da gab es garantiert bei jedem Browser in der Zwischenzeit schon dutzende Updates, die eh regelmäßig installiert sind.

    Das Problem hat also sicher nix mit einem einzelnen ausstehenden Browserupdate zu tun.


  • Internet ist bei mir ne 200MB Kabel Deutschland Leitung und Kabel - Fritz Box

    1x Win7 und 1x Win10 - jeweils nur mit den betriebssystemeigenen Firewall und Antivirenprogrammen

    Browser sind vorrangig Chrome und bisschen auch Firefox, immer in den aktuellen Versionen

  • Wäre ja wirklich schön, wenn man das mal fixt .. ist aber wie gesagt eigentlich schon ein sehr altes Problem und hat sicher keinen Zusammenhang mit der aktuellen HTML5 Umstellung.

    Mit Flash hatte ich das eigentlich nie.


    Mit HTML5 habe ich das immer. Von daher sehe ich das sehr wohl als "HTML5-Problem" an und nicht als ein sehr altes Problem. Deine Schlussfolgerungen sind also nicht allgemeingültig, Saturnin.


    Browser Firefox. Keine Firewall, Keine Aneivirensoftware und unabhängig davon, ob meine Internetverbindung gerade schnell oder langsam ist: Der Tab muss offen sein, sonst wird der Ladevorgang nicht abgeschlossen.

  • Das "Problem" hat gar nichts mit dem Spiel zu tun.

    Tabs im Hintergrund haben niedrigste Priorität für den Browser, und die meisten halten Ladevorgänge in nicht aktiven Tabs automatisch an.

    Dazu braucht man keine Updates. Weder für das Game, noch für den Browser.

    Wenn man etwas laden will, sollte man den Tab halt solange im Vordergrund halten.

  • Ich kenne das auch nicht anders. Wenn ich doch mal den Tab innerhalb des Ladevorgangs wechsele, dann bleibt er stehen. Da ich das aber als Systembedingt angesehen habe, so wie Freedriver das so schön beschrieben hat, hab ich es nicht als Bug angesehen. Also wenn man daran was ändern kann, bitte schön gern, aber ansonsten hätte es für mich niedrige Priorität.


    Gruß

  • Von daher sehe ich das sehr wohl als "HTML5-Problem" an

    hmm, also ich spiele aktuell 2 Live Server und 1 PTR.

    Der PTR ist HTML 5, die beiden Live Server aber noch nicht - Beide USA, beide EP6 und beide aktuell im ES.

    Und dort erlebe ich das geschilderte gleichermaßen jeden Tag und eben auch in schon vielen vorherigen Runden.


    Nun sag mir wie kann das ein spezielles HTML5 Problem sein, wenn diese Server weder aktuell noch bisher auch nur im entferntesten mit HTML5 und der Umstellung darauf zu tun hatten.


    Und wie gesagt, ich erlebe dieses stehenbleibende Einloggen seit langem, da ich häufig mit mehreren Tabs arbeite.

    Entschuldige also aufrichtig, wenn mir da der Zusammenhang zu HTML5 wirklich abgeht.

  • Ich habe aktuell bis zu 4 RN-Tabs aber nur selten auch alle 4 offen.


    Flash lädt immer im Hintergrund bis ich auf der Map bin.

    HTML5 nie.


    Verallgemeinerungen und Schlussfolgerungen für allgemeingültig zu erklären ist immer problematisch. Deshalb sind meine Posts grundsätzlich in der Ich-Form gehalten.

  • - Internetgeschwindigkeit

    - Firewall

    - Antivirensoftware

    16 MBit

    Windows Firewall

    keine, die im Browser rumpfuscht (Microsoft Defender)

    wenn ich`s mal so sagen darf ....

    das ist doch kein neues spezifisches HTML Problem


    Das grade das Einloggen in einzelne Spielwelten pausiert und dazugehörige Ladebalken stehen bleiben, wenn ich den Tab wechsel und somit die RN Welt in den Hintergrund schiebe und einen anderen Tab aktiv habe.

    das kenne ich schon seit Jahren so und war somit unter Flash schon genauso.

    Das ist leider Spielalltag seit langer Zeit.

    Doch, bei Flash ist das anders. Sobald sich im ersten schwarzen Bildschirm beim Ladebalken was tut kann man normalerweise wegschalten und man den Tab wechseln während es im Hintergrund zu Ende lädt.


    Bei HTML5 bleibt der Ladebalken immer stehen wenn man wegschaltet bevor man bei 70-80% ist.


    Bei Flash passiert das unter anderen Umständen.

  • es geht ja ums laden....

    Wenn das Spiel geladen ist, läuft es auch bei 10 Tabs munter weiter.....

    Der eigentliche Ladevorgang wird bei nem Hintergrundtab aber unterbrochen. Bei HTML5 direkt, bei Flash evtl. nicht bzw. verzögert....

    Es bleibt dabei: Während geladen wird Tab im Vordergrund behalten, danach kann man beliebig wechseln.

  • Flash lädt immer im Hintergrund bis ich auf der Map bin.

    HTML5 nie.

    HTML5 lädt auch im Hintergrund, nur viiiiel länger.

    Ist vergleichbar mit den Videos. Dort starte ich ein Video und wechsel den Tab, auch hier braucht es unter HTML5 bedeutend länger bis es startet.

    Ich habe den Eindruck, dass dies wohl an der schwachen Performance der HTML-Server liegt.

                                     Mit Würde erlangt man Achtung. Mit Güte gewinnt man die Massen.

                                                                  - Konfuzius -

  • Zumindest Chrome schaltet Tabs im Hintergrund auf niedrigste Priorität - klappt vermutlich besser mit HTML als mit Flash, deswegen merkt man das jetzt mehr als vorher.

    Siehe Background Tabs in Chrome 57 | Web | Google Developers, kann auch deaktiviert werden - der Server hat direkt nichts mit dem Rendern der Seite zu tun und bremst nicht, solange der Requests schnell genug beantwortet.

    Für einen Burnout fehlt mir einfach die Zeit.

  • - Internetgeschwindigkeit

    - Firewall

    - Antivirensoftware

    - Browser (gilt speziell für Quedel, da hilti2 es ja schon geschrieben hat)

    Hallo.


    Tritt auf allen genutzten Rechnern auf.


    Rechner 1: Win10 1803, 100MBit/s-Leitung, Norton Security (Firewall+AV), Edge-Browser

    Rechner 2: Win10 1903, 16MBit/s-Leitung (allerdings viele Rechner an der Leitung), McAfee-Security Suite, Edge-Browser.


    Wie gesagt, ist kein neues Problem, ein altes. Nur mit dem Unterschied, das bei HTML5 anscheinend der Ladebalken dann weiter ging, während er vor der Umstellung zumindest optisch von vorne anfing (ob die Zeit ein Unterschied war, kann ich nicht sagen).

    Mein PC: Win10 Pro 64bit, spiele mit Edge/v44, 16 GB RAM, i7-6400K-Prozessor, Nvidia GTX 970 mit 4 GB RAM

    Und nein, ich installiere mir keinen anderen Browser. Ich ruf ja auch nicht bei der Stadt an und sage "da ist ein Schlagloch, was repariert werden muss" und bekomm zur Antwort "Kaufen sie sich doch ein anderes Auto".