Very Buggy

  • Constantly have to reload game to keep it working. All sorts of little glitches. The developers should really play the game for a few hours a day in order to see all the little annoying things going on.. Many little glitches that are difficult to describe, but guarantee you will experience them if you take the time to play, game programmers. I think the game will lose a lot of players if it doesnt get a whole lot better than it is now. Flash was bad enough, this is worse.

  • OK, examples. Dont like having to reload the game constantly to keep it running properly. The visuals/graphics are not correctly aligned, some things are just off center, or sometimes you have to reload the game to see things in proper perspective. Game is slower to respond than it was even with flash. It is slow enough you dont think it will even respond at all sometimes. When you change screens you have to wait for all the graphics to load, it isnt smooth, but rather is choppy loading and very slow.

    It also takes longer to load the game than the other platform, which is most annoying since you have to reload the HTML format more often to keep it running properly. The set schedules dont seem to be working correctly. As I said, I really think the developers just need to play the game to see what sort of things are not performing well or what sorts of things are annoying.

  • The videos have some snafus also. When your widget shows you have videos, and you try to watch them nothing happens. So you take a full 60 seconds to go to your station page which is very slow to load, or maybe you have to reload the whole game in order to get it to work, then when you finally get there, it shows you have no videos to watch. So you go back out and the widget still shows you have videos to watch.

  • very choppy, can visually see the trains skipping on the tracks. clicks to do anything take way to long to register. Load times are very long for anything. logging on, iloading of Train list, Loading of Station buildings. Loads of mail.. all of it loads or takes way long to even register its been clicked. please fix this I will no longer be able to play

  • So it will not load ..... I click play now from the game world selection screen ..... the screen turns all black then loads the rail nation logo with the red loading bar underneath then switches to the yellow and white train coming at you with what looks like bugs smashed all over the front(very good detail btw) then the red loading bar at the bottom fills up and the screen turns white and then starts flashing random blue and white triangles and lines .... no 2 the same and I have never had this happen before only on s201 I let it go for maybe 30 seconds the first time and this time it has been doing it for the whole time I have been typing this plus 5 minutes ...... anyone else?? do I need to turn something off/on?? HELP!!