system requirements

  • Why isn't Travian telling what the miminum system requirements are to play the game under HTML5, the same as all other gaming companies do? I really hope you know them.


    I see so many people whining about poor speed, other performance issues etc. etc. I think when this is somewhere clear stated most can check if their system will meet the requirements or not.

    People who don't meet the requirements can stop with repeating complaints what lots of others wrote before them and it will become hopefully easier to find causes why people have issues with systems who are suitable for the game.


    I have seen people reacting who are using old systems, not suitable anymore to play nowadays games.

    - - - - - - - - - - - - - - - - -:engine1::engine1::engine1: - - - - - - - - - - - - - - - - - - - - -

    If a turtle doesn’t have a shell, is he homeless or naked?

  • Mostly because it doesn't seem to matter what system you have. A lot of people got problems with very good computers. It currently mostly depends on the browser. If you use Firefox or Chrome the game barely runs, if you use Brave everything is fine.

  • Mostly because it doesn't seem to matter what system you have. A lot of people got problems with very good computers. It currently mostly depends on the browser. If you use Firefox or Chrome the game barely runs, if you use Brave everything is fine.

    Chrome and edge chromium are working perfect for me. I see a lot of people who have real old systems which are not suitable anymore to play any modern game.The minimum system requirements should be announced somewhere clear to see for everybody.

    - - - - - - - - - - - - - - - - -:engine1::engine1::engine1: - - - - - - - - - - - - - - - - - - - - -

    If a turtle doesn’t have a shell, is he homeless or naked?

  • Hey



    Reading here in forum about HTLM 5 make me a bit worried (understatement) so i just wanted to make a try before my real game (Loch Ness) started, so i just try Tower Bridge with new Browser Brave and so far NO ISSUE at all - runs like old game, if this is standard i am NOT worried so cross my fingers for next days testing


    Cheers ( a bit more optimistic) Rype



    Just try it in Chrome and run even more flawless - so far no issue at all

    The post was edited 1 time, last by Rype ().

  • Now on day 2 of test


    Just added one more Gameworld Brandenburger Tor and still no issue on Chrome or Brave all run as it should with two tabs open at same time


    Still not seen any strange behavior on HTLM 5

  • Hey


    Intel Core I7-8750H CPU @ 2,2 GHz

    8GB Ram

    NVIDIA GeForce GTX 1050Ti

    I got 1000/1000 Mbps into my house but in my office at home on Wifi i only got around 60/80 Mbps


    Not sure where i can see my Frames

  • I play 3 servers at the moment and all opened at the same time without problems. I have to refresh less.


    Intel Core i5-94400T (6 cores)

    1.8 Ghz (max turbo 3.4Ghz)

    motherboard Intel H370

    RAM 8GB DDR4 2.400MT/s (free 7.71 GB)

    256 Mb SSD 1TB HDD

    video card Intel UHD Graphics 630

    - - - - - - - - - - - - - - - - -:engine1::engine1::engine1: - - - - - - - - - - - - - - - - - - - - -

    If a turtle doesn’t have a shell, is he homeless or naked?