Profit per hour is grossly wrong when boost is applied

  • As title, when boost (the +20km/h voucher thing) is applied to a train, the timetable calculator/ schedule shows it has a ridiculously high profit/h.

    (E.g. A 120km/h train originally have a profit of 2M/h, after applying the boost it "shows" 8M/h)

    The roundtrip time is also grossly wrong. (E.g. A 120km/h train originally have a roundtrip time of 24min, after applying the boost it "shows" 7min).


    This should be reproduced easily as it happens every time , on every world I play, when the boost is applied

    (Use multi-slot pax trains to feel the wildest bug result)


    Note that speed worker works properly.

  • The travel time is also wrong when boost is applied. Pretty big problem if you're doing competitions.

    Glaring bug, easy for everyone to see, including the support, tech and dev staff. But anyone mentioning it or just fixing it? No no no, of course not, they will wait until at least 5k players send a ticket then maybe it will be added to the long list of bugs to fix during the next century.

    It would be funny if it really wasn't funny at all.

    If it ain't Dutch, it ain't much!

  • The travel time is also wrong when boost is applied. Pretty big problem if you're doing competitions.

    Glaring bug, easy for everyone to see, including the support, tech and dev staff. But anyone mentioning it or just fixing it? No no no, of course not, they will wait until at least 5k players send a ticket then maybe it will be added to the long list of bugs to fix during the next century.

    It would be funny if it really wasn't funny at all.

    Probably will be added to list of bug after 1,000 HTML5 QA sessions while the most obvious bug currently is the game crashes every 1-5 mins and you have to refresh. All hail Refresh Nation