Rail Nation Hell

  • I was getting ready to run a passenger competition. I like to run my engines in packs... I noticed that I had a few that had got separated and were lagging behind. So I decided to execute a park multiple engines command and rally my engines. Most of them parked and were Zzz in the city... but a few were missing? I tried to locate them but, as they sometimes do these days, they had vanished. So I thought, no problem a quick refresh will fix everything...


    OMFG... I hit refresh and the game seemed to hang up loading, which it sometimes does, which is a bit frustrating when you have most of your engines parked. So I thought, no problem maybe it's time to clear the cache, which I do from time to time, and things may load a bit smoother.


    The competition started at 01:30 UTC... I decided to park my engines and do a quick refresh a bit more than 10 minutes before it started...


    After almost two hours of the game trying to load, sometimes almost load... again and again and again and again... I'd get to the start page and it wouldn't quite load... the game wouldn't start to load... once it actually started to load... then after almost two hours the home page wouldn't even load anymore.


    HELL!!!


    I know it's just a game... but I had a title I was trying to defend... I know it's just a game but the titles mean a lot to me :(


    It's gone for sure after being parked over two hours now... I know it's just a game and it really shouldn't be that big of a deal... but it is.

    I should just stop trying to log in for a couple of hours and not let it bother me... but my bloody engines ARE PARKED!!! I NEED TO GET BACK IN ASAP!!!! DAMNIT!!!!

    Rail Nation Digital Railway Tycoon

    COM03 Smoke Chamber

  • The other day I could not log into Masters on my computer, it took about four minutes on my phone. Meanwhile I was able to log into Crankshaft and Grand Central with no issue. It's just a RN thing. Gremlins I suppose.

  • Hi Comrade Sam!


    If all I had was your problems, I guess that would be an improvement


    Check mine


    takes me 5 times to sign up for a contest thats if I dont have to use select all multiple times just to get the trains to do what i want.


    When using the tables for train routes. My phone wants to kill the app cause it says it stopped responding. Also they don't update properly unless you log off and come back in AFTER the hourly recalc. Even then not so sure cause on the facilties growth tab.... all kind of numbers. Go to a facilty and look and its already leveled.


    Messages.

    Constant refresh issues. Can never type more than a few words. End up pasting and submitting. But then submit takes multiple attempts as well... sometimes goes thru multiple times.


    Usually have to close game every 3-4 minutes due to nothing working. Ie get blank place holders. Messages won't show who its from. Comps won't open, nothing works.


    Investing

    I hit it once and it goes grey. No idea if my investment took. Maybe a minute or two later it will allow me to see it or have to log off.


    I play on my phone. Its an android and latest model. Its not on my side. Otherwise all servers I play on would do the same.


    Also, I am not the only person having this issue.


    Please escalate it to the next level the game is super hard for me to enjoy playing because it doesn't function correctly. We are in early era 5. This has been happening all round long. But kicked up a notch in era 3 and again in era 4.


    Its very encumbersome. Please stop adding new content til everything works as advertised. IF it has anything to do with me being connected to 50 cities then lower the amount of cities down to a level that the server can handle.


    TIRED